sábado, 17 de março de 2012

perlbrew em Ubuntu 11.10

O perlbrew é um utilitário que permite instalar e utilizar várias versões de Perl, obviando a necessidade de mexer no Perl do sistema (em regra, uma má ideia).

Sucede, contudo, que as versões mais recentes de Ubuntu (eventualmente, também Debian) não permitem compilar os perls sem introduzir opções adicionais de compilação.

As linhas seguintes permitem instalar a versão 5.14.2 via perlbrew em sistemas de 32 e 64 bits, respetivamente:


$ perlbrew install perl-5.14.2 -Dusethreads -Duselargefiles -Dcccdlflags=-fPIC -Dpager=/usr/bin/sensible-pager -Doptimize=-O2 -Duseshrplib -Darchname=i386-linux-gnu -Dccflags=-DDEBIAN -Dplibpth=/usr/lib/i386-linux-gnu


$ perlbrew install perl-5.14.2 -Dusethreads -Duselargefiles -Dcccdlflags=-fPIC -Dpager=/usr/bin/sensible-pager -Doptimize=-O2 -Duseshrplib -Duse64bitall -Darchname=x86_64-linux-gnu -Dccflags=-DDEBIAN -Dplibpth=/usr/lib/x86_64-linux-gnu

1 comentário: